VMware ESXi 主机与交换机之间的链路聚合

2021年01月12日 52点热度 0人点赞 0条评论

VMware ESXi 主机与交换机之间的链路聚合配置示例。本文示例是在模拟器环境下配置的,仅配置一台ESXi主机(不配置vCenter),在物理环境可能不适用;不同的ESXi版本和不同的交换机之间配置可能也不同,仅供参考。

环境

模拟器:EVE-NG
ESXi版本:6.7
交换机:Cisco

拓扑

拓扑
拓扑
拓扑2
拓扑2

配置

主要配置步骤

  1. 配置ESXi主机,让Web界面可以访问。可直接用电脑连接到ESXi主机的管理口。
  2. 修改ESXi虚拟交换机上行链路的负载均衡模式,从默认的“基于源端口ID的路由”修改为“基于IP哈希的路由
  3. 配置ESXi主机和交换机之间的链路聚合。链路两端都配置为静态链路聚合,不使用LACP协议

修改ESXi主机负载均衡模式

ESXi主机启动完成后,查看管理口是哪个接口,默认只有一个网口是管理口。然后修改管理口的IP,VLAN可以先不用设置。管理口的IP即默认虚拟交换机的VM Kernal端口组的IP。

管理口默认只有一个网卡
管理口默认只有一个网卡

电脑直接连接到ESXi主机管理口,配置与管理口相同网段的IP。登录Web界面,修改虚拟交换机上行链路的负载均衡模式。默认的负载平衡为“基于源端口ID的路由”。

选择“网络”--“vSwitch0”--“编辑设备”--“网卡绑定”

默认负载平衡-基于源端口ID的路由
默认负载平衡-基于源端口ID的路由

修改为“基于IP哈希的路由”

修改为基于IP哈希的路由
修改为基于IP哈希的路由

 

配置链路聚合

ESXi主机

ESXi默认的虚拟标准交换机的上行链路默认开启链路聚合,只需要添加上行链路到虚拟交换机即可。但这是静态的或强制的链路聚合,并没有使用LACP协议。因此对端的交换机也要配置成静态的链路聚合。这是只配置一台ESXi主机到交换机的链路聚合,不涉及vCenter、分布式交换机等。

ESXi管理网络的上行链路可以在主机界面添加

将其他网卡设置为管理口
将其他网卡设置为管理口

也可以在WEB界面添加,即给虚拟交换机添加上行链路。

交换机配置

interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on #静态、强制链路聚合,不使用LACP协议
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on #静态、强制链路聚合,不使用LACP协议

在交换机上查看链路聚合的相关配置

查看摘要信息

SW-esxi#sh etherchannel summary 
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator

        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

        A - formed by Auto LAG


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)          -        Gi0/1(P)    Gi0/2(P)    

查看详细信息

SW-esxi#sh etherchannel detail

查看链路聚合的负载均衡模式

SW-esxi#show etherchannel load-balance 
EtherChannel Load-Balancing Configuration:
  src-dst-ip
默认模式,不用修改

修改链路聚合的负载均衡模式

SW-esxi(config)#port-channel load-balance ?
  dst-ip       Dst IP Addr
  dst-mac      Dst Mac Addr
  src-dst-ip   Src XOR Dst IP Addr
  src-dst-mac  Src XOR Dst Mac Addr
  src-ip       Src IP Addr
  src-mac      Src Mac Addr

 

参考资料

VMware官方文档

https://kb.vmware.com/s/article/1001938?lang=zh_CN

  • ESXi/ESX 主机仅支持在一个物理交换机或堆栈交换机上实现网卡绑定。
  • 不同的中继交换机上从不支持链路聚合。
  • 交换机必须设置为在静态模式打开时执行3ad 链路聚合,虚拟交换机的负载平衡方法必须设置为基于 IP 哈希的路由。确保参与的网卡已连接到相同物理交换机上配置的端口。
  • 在没有3ad 聚合(或相反情况)时启用基于 IP 哈希的路由将中断网络,因此必须先对虚拟交换机进行更改。这样,服务控制台将不可用,但物理交换机管理接口可用,因此可在相应端口上启用聚合以还原网络。
  • 有关 ESXi/ESX 网络概念的详细信息,请参见VMware Virtual Networking Concepts
  • 有关网卡绑定的 VLAN 配置的详细信息,请参见VLAN Configuration on Virtual Switch, Physical Switch, and Virtual Machines (1003806)
  • 要在 ESXi/ESX 和物理交换机上配置网卡绑定,请参见Sample configuration of EtherChannel / Link Aggregation Control Protocol (LACP) with ESXi/ESX and Cisco/HP switches (1004048)
  • vSphere Distributed Switch 5.1 中的 LACP 支持仅支持 IP 哈希负载平衡。在 vSphere Distributed Switch 5.5 中,支持所有 LACP 负载均衡算法。 有关更多信息,请参见LACP Support on a vSphere Distributed Switch
  • 请勿将信号探测与 IP HASH 负载平衡结合使用。
  • 请勿使用 IP HASH 负载平衡配置备用或未使用的上行链接。
  • VMware 只支持每个虚拟标准交换机 (Virtual Standard Switch, vSS) 具有一个 Etherchannel 绑定。在 vSphere 5.5 之前,使用虚拟分布式交换机 (Virtual Distributed Switch, vDS) 时,每个 ESXi/ESX 主机在每个 vDS 上只能配置一个 etherchannel 绑定。
  • ESXi 5.1、5 和 6.0 在 vDS 上只支持 LACP。有关详细信息,请参见Enabling or disabling LACP on an Uplink Port Group using the vSphere Web Client (2034277)

 

arben

文章评论